Cloudflare System Status

Network Performance Issues in Egypt
Incident Report for Cloudflare
Resolved
This incident has been resolved and traffic has been restored to our Cairo data center.
Posted Jun 21, 2016 - 20:45 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 21, 2016 - 13:24 UTC
Investigating
CloudFlare is observing network performance issues in Cairo, Egypt. We are actively working to reduce or eliminate any impact to Internet users in this region.
Posted Jun 21, 2016 - 10:43 UTC