Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Oct 22, 2019 - 11:19 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 22, 2019 - 10:56 UTC
Investigating
Cloudflare is investigating delays for creating or updating DNS records that use Argo Tunnel. This does not impact active connections through Argo Tunnel.
Posted Oct 22, 2019 - 10:36 UTC
This incident affected: Cloudflare Sites and Services (Argo Tunnel, DNS Updates).