Cloudflare System Status

Network Performance Issues in Kiev, Moscow & Helsinki
Incident Report for Cloudflare
Resolved
This incident has now been resolved.
Posted Sep 14, 2016 - 11:40 UTC
Identified
We have re-routed all traffic in Kiev, Moscow & Helsinki - visitors will be served from other nearby locations on our network
Posted Sep 14, 2016 - 06:59 UTC
Investigating
CloudFlare is observing network performance issues in Kiev, Moscow & Helsinki. We are actively working to reduce or eliminate any impact to Internet users in this region.
Posted Sep 14, 2016 - 06:59 UTC
This incident affected: Europe (Helsinki, Finland - (HEL), Kyiv, Ukraine - (KBP), Moscow, Russia - (DME)).