Cloudflare System Status

Problems with Enterprise Log Share
Incident Report for Cloudflare
Resolved
This incident has been resolved and Enterprise Log Share (ELS) is functioning normally now.
Posted May 05, 2016 - 16:24 UTC
Investigating
Some users may experience delays accessing the log share service. We are actively working on a fix.
Posted May 05, 2016 - 15:29 UTC
This incident affected: Cloudflare Sites and Services (Logs).