Cloudflare System Status

Cloudflare Billing Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Oct 15, 2019 - 03:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2019 - 02:53 UTC
Investigating
Cloudflare is experiencing an issue with billing subscription services and users may experience problems with signing up for paid services or making changes to billing details. All other services are operating normally.

We will provide an update once billing services return to normal.
Posted Oct 15, 2019 - 02:45 UTC
This incident affected: Cloudflare Sites and Services (Billing).