Cloudflare System Status

Connection issue in North America
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Nov 04, 2019 - 04:22 UTC
Investigating
Cloudflare is investigating connection issues in North America
Posted Nov 04, 2019 - 03:38 UTC