Cloudflare system status
DNS Update Delays in some United States locations
Incident Report for Cloudflare
Resolved
This issue has been resolved in all locations.
Posted about 2 months ago. Apr 13, 2017 - 12:23 UTC
Update
The DNS update delays have been resolved in Phoenix, AZ, St. Louis, MO, and Denver, CO. Work to fix the delays is continuing in Los Angeles, CA, and we will update once we have confirmed they have been resolved.
Posted about 2 months ago. Apr 13, 2017 - 10:35 UTC
Monitoring
We have implemented a fix for this issue and are currently monitoring the results. We will update once we have confirmed it is resolved.
Posted about 2 months ago. Apr 13, 2017 - 04:04 UTC
Investigating
Cloudflare is investigating delays in making updates to DNS records.

We are observing delays of up to 30 minutes in updates to DNS records in the United States in Los Angeles, CA, Phoenix, AZ, St. Louis, MO, and Denver, CO. Cloudflare DNS service delivery is still available: only DNS updates and changes are delayed.
Posted about 2 months ago. Apr 12, 2017 - 22:54 UTC