Cloudflare System Status

Credit Card Billing Outage
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 11, 2018 - 15:59 UTC
Identified
We are currently experiencing problems making changes to our credit card billing service. This may also partially affect the cloudflare.com website and its related APIs. This incident does not affect the Cloudflare CDN and therefore the delivery of customer websites is not impacted. We expect this to be operational again by 16:00 UTC. We will post an update once credit card billing services have returned to normal.
Posted 9 months ago. Mar 11, 2018 - 13:35 UTC
This incident affected: Cloudflare customer dashboard and APIs (Cloudflare.com, Billing).