Cloudflare System Status

Investigating network congestion
Incident Report for Cloudflare
Resolved
Incident resolved
Posted Jun 04, 2015 - 06:27 UTC
Monitoring
We've identified the cause of congestion and mitigated the impact.
Posted Jun 04, 2015 - 03:51 UTC
Investigating
We're receiving reports of network congestion in Los Angeles and San Jose areas

Investigating.
Posted Jun 04, 2015 - 03:35 UTC
This incident affected: North America (Los Angeles, CA, United States - (LAX), San Jose, CA, United States - (SJC)).