Cloudflare System Status

Network Performance Issues in Frankfurt and Amsterdam
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 06, 2020 - 10:17 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 06, 2020 - 08:19 UTC
Identified
Cloudflare has identified issues with network performance in Frankfurt and Amsterdam.

We are working to mitigate this problem. More updates to follow shortly.
Posted Mar 06, 2020 - 08:17 UTC
This incident affected: Europe (Amsterdam, Netherlands - (AMS), Frankfurt, Germany - (FRA)).