Cloudflare System Status

Investigating network congestion in Amsterdam
Incident Report for Cloudflare
Resolved
This issue has now been resolved
Posted May 24, 2016 - 16:05 UTC
Investigating
We are investigating issues with performance in our Amsterdam location

Investigating.
Posted May 24, 2016 - 15:58 UTC
This incident affected: Europe (Amsterdam, Netherlands - (AMS)).