Cloudflare System Status

Network Performance Issues in Amsterdam and Frankfurt
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and normal services have resumed.
Posted 3 months ago. May 21, 2019 - 06:48 UTC
Investigating
Cloudflare is observing network performance issues in Amsterdam and Frankfurt. We are actively working to reduce or eliminate any impact on Internet users in these regions.
Posted 3 months ago. May 21, 2019 - 06:29 UTC
This incident affected: Europe (Amsterdam, Netherlands - (AMS), Frankfurt, Germany - (FRA)).