Cloudflare System Status

DNS Propagation Delays
Incident Report for Cloudflare
Resolved
This incident is now resolved. Updates to DNS records have now returned to normal.
Posted 2 months ago. Feb 05, 2019 - 15:55 UTC
Investigating
Cloudflare is investigating delays in updates to DNS records. These delays affect record changes and updates.

DNS resolution is operating with normal latency.
Posted 2 months ago. Feb 05, 2019 - 14:59 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).