Cloudflare System Status

Network Performance Issues in Zurich (ZRH)
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and services have resumed normal operation.
Posted about 1 month ago. Jun 19, 2019 - 09:18 UTC
Monitoring
Cloudflare has implemented a fix for this issue and is currently monitoring the results.

We will update the status once the issue is resolved.
Posted about 1 month ago. Jun 19, 2019 - 09:11 UTC
Identified
Cloudflare is observing network performance issues in Zurich.

We are working to mitigate impact to Internet users in this region.
Posted about 1 month ago. Jun 19, 2019 - 09:09 UTC
This incident affected: Europe (Zürich, Switzerland - (ZRH)).