Cloudflare System Status

SSL Certificate Provisioning Delays
Incident Report for Cloudflare
Resolved
We have cleared the backlog of SSL orders, and new SSL orders should no longer experience any delays. Please contact support if you experience any further issues.
Posted Nov 10, 2016 - 17:07 UTC
Monitoring
There is a backlog of SSL orders which are currently being processed. Delays in provisioning of new SSL Certificates is down to 10 minutes. We will continue to monitor the processes until the backlog has been cleared.
Posted Nov 10, 2016 - 02:13 UTC
Investigating
Cloudflare is investigating SSL Certificate Provisioning Delays.

We are observing delays of up to 45 minutes in provisioning new SSL Certificates. Cloudflare's TLS/SSL service is still available; only provisioning of new SSL Certificates is delayed.
Posted Nov 09, 2016 - 22:59 UTC
This incident affected: Cloudflare Sites and Services (SSL Certificate Provisioning).