Cloudflare System Status

Investigating Network Related Issues in London.
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 20, 2015 - 18:44 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 20, 2015 - 18:23 UTC
Investigating
We’re receiving reports of network related issues in London.
Posted Jun 20, 2015 - 18:17 UTC
This incident affected: Europe (London, United Kingdom - (LHR)).