Cloudflare System Status

Investigating network congestion
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 25, 2016 - 03:35 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2016 - 00:23 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 24, 2016 - 23:20 UTC
Investigating
We're receiving reports of network congestion in our upstream's network.
Milan, IT and Cairo, EG. Both colos have been rerouted.

Investigating.
Posted Apr 24, 2016 - 22:55 UTC
This incident affected: Europe (Milan, Italy - (MXP)).