Cloudflare System Status

Network Performance Issues in Western North America
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 17, 2020 - 21:57 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 17, 2020 - 21:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2020 - 21:09 UTC
Investigating
Cloudflare is investigating issues with network performance in Western North America.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted Mar 17, 2020 - 20:50 UTC
This incident affected: North America (San Jose, CA, United States - (SJC)).