Cloudflare System Status

Network Performance Issues in Minneapolis, MN
Incident Report for Cloudflare
Resolved
This issue has been resolved.
Posted 12 months ago. Oct 02, 2017 - 07:26 UTC
Monitoring
We have implemented a fix for this issue and are currently monitoring the results. We will update once we have confirmed it is resolved.
Posted 12 months ago. Oct 02, 2017 - 03:39 UTC
Investigating
Cloudflare is observing network issues with Charter Communications in Minneapolis, MN. We are actively working to reduce or eliminate any impact to Internet users in this region.
Posted 12 months ago. Oct 02, 2017 - 02:09 UTC
This incident affected: North America (Minneapolis, MN, United States - (MSP)).