Cloudflare System Status

Investigating congestion in San Jose
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jul 21, 2015 - 12:56 UTC
Investigating
We're investigating reports of network congestion in San Jose.
Posted Jul 21, 2015 - 12:31 UTC
This incident affected: North America (San Jose, CA, United States - (SJC)).