Cloudflare System Status

Investigating Network Related Issues in St. Louis, MO
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Sep 21, 2016 - 09:50 UTC
Identified
The issue has been identified and a fix is being implemented. Traffic has been re-routed to other locations and service should not be affected.
Posted Sep 20, 2016 - 17:53 UTC
Investigating
Cloudflare is observing network performance issues in St. Louis. We are actively working to reduce or eliminate any impact to Internet users in this region.
Posted Sep 20, 2016 - 17:45 UTC
This incident affected: North America (St. Louis, MO, United States - (STL)).