Cloudflare System Status

Investigating Network Related Issues Montreal
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Feb 21, 2016 - 11:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 21, 2016 - 10:45 UTC
Investigating
We’re receiving reports of network related issues in Montreal.
Posted Feb 21, 2016 - 10:41 UTC
This incident affected: North America (Montréal, QC, Canada - (YUL)).