Cloudflare System Status

Billing Service Maintenance
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 15, 2018 - 05:05 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2018 - 03:45 UTC
Investigating
We are performing maintenance on our subscription services. For approximately 2 hours you may see a delay in processing changes to subscriptions. All other services are operating normally. We will post an update once the maintenance is complete.
Posted Mar 15, 2018 - 02:17 UTC
This incident affected: Cloudflare Sites and Services (Billing).