Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
This issue with DNS delays has been resolved has returned to normal.
Posted Feb 02, 2017 - 23:20 UTC
Investigating
We have identified the source of the DNS delays and have reduced the delays down to 10 minutes.
Posted Feb 02, 2017 - 19:09 UTC
Identified
Cloudflare is investigating delays in making updates to DNS records.
We are observing delays of up to 50 minutes in updates to DNS records. CloudFlare's DNS service delivery is still available: only DNS updates and changes are delayed.
Posted Feb 02, 2017 - 18:31 UTC