Cloudflare System Status

Network issues in SIN
Incident Report for Cloudflare
Resolved
Network issues in Singapore have been resolved.
Posted Nov 21, 2014 - 22:37 UTC
Investigating
We are investigating upstream networking issues in Singapore.
Posted Nov 21, 2014 - 21:31 UTC