Cloudflare System Status

Investigating DNS propagation delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 12, 2015 - 19:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2015 - 18:29 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 12, 2015 - 18:08 UTC
Investigating
We are currently investigating this issue.
Posted Jun 12, 2015 - 17:57 UTC