Cloudflare System Status

Spectrum connection instability
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 30 days ago. Aug 22, 2019 - 04:06 UTC
Identified
Cloudflare is observing Spectrum connection instability in some regions. We are working to resolve this issue as soon as possible.
Posted 30 days ago. Aug 22, 2019 - 00:07 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Spectrum).