Cloudflare System Status

Network Performance Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 09, 2018 - 14:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Jul 09, 2018 - 13:32 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 2 months ago. Jul 09, 2018 - 12:57 UTC
Investigating
Cloudflare is observing network performance issues in Athens, Greece. We are actively working to reduce or eliminate any impact to Internet users in this region.
Posted 2 months ago. Jul 09, 2018 - 10:00 UTC
This incident affected: Europe (Athens, Greece - (ATH)).