Cloudflare system status
DNS Update Delays
Incident Report for Cloudflare
Resolved
This issue with DNS delays has been resolved has returned to normal.
Posted 21 days ago. Feb 03, 2017 - 05:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 21 days ago. Feb 03, 2017 - 04:29 UTC
Investigating
Cloudflare is investigating delays in making updates to DNS records.

We are observing delays of up to 35 minutes in updates to DNS records. Cloudflare's DNS service delivery is still available: only DNS updates and changes are delayed.
Posted 21 days ago. Feb 03, 2017 - 04:16 UTC