Cloudflare System Status

Investigating Network Related Issues in Milan, colo re-routed.
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 22, 2015 - 00:10 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 21, 2015 - 22:06 UTC
Investigating
We’re receiving reports of network related issues in Milan.
Posted May 21, 2015 - 22:03 UTC
This incident affected: Europe (Milan, Italy - (MXP)).