Cloudflare System Status

DNS propagation delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 31, 2016 - 14:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 31, 2016 - 13:41 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 31, 2016 - 11:42 UTC
Investigating
We've identified delays in propagating DNS changes across the CloudFlare network. Updates to DNS may take longer than expected to become available.

DNS lookups themselves are not affected by this.
Posted Mar 31, 2016 - 10:41 UTC
This incident affected: Cloudflare Sites and Services (API, Dashboard).