Cloudflare System Status

Delay in Workers and Pages updates
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Nov 17, 2022 - 18:11 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2022 - 17:58 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 17, 2022 - 17:22 UTC
Investigating
Cloudflare is experiencing delays in updating Workers on the edge and executing new Cloudflare Pages deployments. This does not impact existing Workers and Pages projects already deployed in production.

We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted Nov 17, 2022 - 16:43 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Workers, Cloudflare Pages).