Cloudflare System Status

Page Rule Propagation Delays
Incident Report for Cloudflare
Resolved
This issue has been resolved and Page Rule Propagation has returned to normal.
Posted 4 months ago. Jun 12, 2018 - 19:46 UTC
Investigating
Cloudflare is experiencing Page Rule propagation delays and we are actively working to resolve this issue.
Posted 4 months ago. Jun 12, 2018 - 18:16 UTC
This incident affected: Cloudflare customer dashboard and APIs (Cloudflare.com).