Cloudflare System Status

Billing Service Maintenance
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 3 months ago. Feb 28, 2019 - 03:50 UTC
Investigating
We are performing maintenance on our subscription services. For approximately 30 minutes starting at 1:00 AM UTC/5:00 PM PST you may see a delay in processing changes to subscriptions. All other services are operating normally. We will post an update once the maintenance is complete.
Posted 3 months ago. Feb 28, 2019 - 00:18 UTC
This incident affected: Cloudflare Sites and Services (Billing).