Cloudflare System Status

Investigating network congestion in Dallas
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Sep 03, 2015 - 00:04 UTC
Investigating
We're receiving reports of network congestion in Dallas

Investigating.
Posted Sep 02, 2015 - 19:54 UTC
This incident affected: North America (Dallas, TX, United States - (DFW)).