Cloudflare system status
SSL Certificate Provisioning Delays
Incident Report for Cloudflare
Resolved
This issue has now been resolved and SSL provisioning times have returned to normal. This issue was related to our recently resolved Delays to Settings Changes outlined at https://www.cloudflarestatus.com/incidents/0f49j5jrzzs7.
Posted 3 months ago. May 17, 2018 - 07:29 UTC
Identified
The issue has been identified and a fix is being implemented. We will update once we have confirmed it is working.
Posted 3 months ago. May 16, 2018 - 23:17 UTC
Investigating
Cloudflare is investigating SSL Certificate Provisioning Delays.

We are observing delays in provisioning new SSL Certificates. Cloudflare's TLS/SSL service is still available; only provisioning of new SSL Certificates is delayed.
Posted 3 months ago. May 16, 2018 - 12:58 UTC
This incident affected: Cloudflare customer dashboard and APIs (SSL Certificates).