Cloudflare System Status

DNS/SSL Update Delays in Bucharest
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 15, 2018 - 14:49 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Jun 14, 2018 - 12:53 UTC
Investigating
Cloudflare is investigating delays of up to 50 minutes in making updates to DNS records and SSL configurations in Bucharest, Romania. DNS resolution and SSL functions are still performing correctly - only updates/changes are delayed.
Posted 4 months ago. Jun 14, 2018 - 11:49 UTC
This incident affected: Europe (Bucharest, Romania - (OTP)).