Cloudflare System Status

SSL Certificate Provisioning Delays
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and services have resumed normal operation.
Posted Dec 06, 2019 - 12:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 06, 2019 - 11:23 UTC
Investigating
Cloudflare is investigating delays in provisioning SSL certificates. New SSL certificate provisioning is taking up to 40 minutes.

SSL certificates already in production remain unaffected and are operating normally.
Posted Dec 06, 2019 - 11:03 UTC
This incident affected: Cloudflare Sites and Services (SSL Certificate Provisioning).