Cloudflare System Status

Cloudflare is investigating SSL Ordering Delays.
Incident Report for Cloudflare
Postmortem
Incident Start 2017-05-11 15:13:00 UTC
Incident End 2017-05-13 08:19:00 UTC
Time to detect 10 min (via alert)
Time to engage 30 minutes
Time to restore 41 hours

An outage at the Certificate Authority used for Universal SSL resulted in certificate orders being delayed until service was restored and all accumulated orders could be processed.

Posted May 14, 2017 - 12:38 UTC

Resolved
This issue has been resolved and ordering new SSL certificates has returned to normal.
Posted May 13, 2017 - 08:24 UTC
Update
Since the fix has been applied, we now estimate delays of up to 1 hour for new SSL certificates while the existing backlog is cleared. We will update once we have confirmed this is fully resolved.
Posted May 12, 2017 - 22:32 UTC
Monitoring
We have implemented a fix for this issue and are currently monitoring the results. We estimate delays of up to 8 hours for new SSL certificates while the existing backlog is cleared. We will update once we have confirmed this is fully resolved.
Posted May 12, 2017 - 15:54 UTC
Identified
The issue has been identified and a fix is being implemented. We will update once we have confirmed it is working.
Posted May 12, 2017 - 15:54 UTC
Investigating
We are observing delays in ordering new SSL Certificates. Cloudflare's TLS/SSL service is still available; only ordering of new SSL Certificates is delayed.
Posted May 11, 2017 - 15:15 UTC
This incident affected: Cloudflare Sites and Services (SSL Certificate Provisioning).