Cloudflare System Status

DNS, Page Rule, Settings delays in North America
Incident Report for Cloudflare
Resolved
All locations are now fully caught up and delays have cleared.
Posted May 25, 2016 - 14:39 UTC
Monitoring
Delays are improving as we work to mitigate - more updates to follow
Posted May 25, 2016 - 14:35 UTC
Investigating
We're reviewing DNS, Settings & Page Rules related delays in some of our North American locations. DNS/CDN service delivery is not impacted: only updates and changes are delayed.
Posted May 25, 2016 - 14:28 UTC
This incident affected: North America (Ashburn, VA, United States - (IAD), Atlanta, GA, United States - (ATL), Chicago, IL, United States - (ORD), Miami, FL, United States - (MIA), Minneapolis, MN, United States - (MSP), Montréal, QC, Canada - (YUL), Newark, NJ, United States - (EWR)).