Cloudflare System Status

Page rule changes delayed
Incident Report for Cloudflare
Resolved
Page Rules changes are not delayed.
Posted Mar 02, 2016 - 20:40 UTC
Monitoring
Page Rules are no longer delayed, we're continuing to monitor.
Posted Mar 02, 2016 - 20:28 UTC
Identified
We've identified an issue causing the Page Rules delays and it should be restored soon.
Posted Mar 02, 2016 - 20:08 UTC
Investigating
Updates to edge page rules are delayed. We are investigating.
Posted Mar 02, 2016 - 19:53 UTC
This incident affected: Cloudflare Sites and Services (API, Dashboard).