Cloudflare System Status

DNS delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Dec 20, 2016 - 16:51 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 20, 2016 - 15:43 UTC
Investigating
Cloudflare is investigating delays in making updates to DNS records.

We are observing delays of up to 10 minutes in updates to DNS records. Cloudflare's DNS service delivery is still available: only DNS updates and changes are delayed.
Posted Dec 20, 2016 - 15:43 UTC