Cloudflare System Status

Custom SSL Certificate Provisioning Delays
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and the Custom SSL certificate services have resumed normal operation.
Posted about 2 months ago. Oct 24, 2018 - 05:15 UTC
Investigating
Cloudflare is investigating delays in provisioning Custom SSL certificates.

The Cloudflare TLS/SSL service is unaffected and is operating normally.
Posted about 2 months ago. Oct 24, 2018 - 04:46 UTC
This incident affected: Cloudflare customer dashboard and APIs (SSL Certificates).