Cloudflare system status
Delays to Settings Changes
Incident Report for Cloudflare
Resolved
This issue has now been resolved and Setting Changes times have returned to normal.
Posted 3 months ago. May 19, 2018 - 07:33 UTC
Investigating
We are currently experiencing some delays in propagating Cloudflare settings changes.  We are actively working to eliminate these delays.
Posted 3 months ago. May 17, 2018 - 20:58 UTC