Cloudflare System Status

File purge delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 03, 2016 - 07:54 UTC
Update
We're still experiencing purge delays, we're working to resolve the issue.
Posted Mar 02, 2016 - 22:36 UTC
Identified
We've identified delays in the file purge system. Purge requests may be delayed.
Posted Mar 02, 2016 - 21:20 UTC
This incident affected: Cloudflare Sites and Services (API, Dashboard).