Cloudflare System Status

Investigating network congestion
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 14, 2015 - 06:08 UTC
Identified
We're receiving reports of network congestion in Singapore.
Posted May 14, 2015 - 05:56 UTC
This incident affected: Asia (Singapore, Singapore - (SIN)).