Cloudflare system status
Network Performance Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 3 months ago. May 18, 2018 - 04:29 UTC
Monitoring
We have implemented a fix for this issue and are currently monitoring the results. We will update once we have confirmed it is resolved.
Posted 3 months ago. May 18, 2018 - 03:11 UTC
Investigating
Cloudflare is observing network performance issues in Hong Kong. We are actively working to reduce or eliminate any impact to Internet users in this region.
Posted 3 months ago. May 18, 2018 - 02:50 UTC